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1. Introduction 

The LAS standard was introduced by the Canadian Well Logging Society (www.cwls.org) in 

1989 to standardize the organization of digital log curve information for use on personal 

computers. It did this very successfully and the standard became popular worldwide. 

Originally aimed at oil and gas exploration, it has also become popular for use in exploration 

for other commodities that use digital log curve information such as coal and uranium. LAS 

Version 1.2 was released in 1990 and was followed in 1992 by LAS version 2.0 to address 

some inconsistencies. The LAS 2.0 version is viewed as a log data exchange format and 

remains the dominant product. 

 

In 1999, the LAS 3.0 version was introduced to provide expanded data storage capabilities 

that include not only log curve data, but also core, inclinometry, drilling, formation tops and 

test data. LAS 3.0 is viewed as a wellbore data storage format and continues to see limited 

implementation. Due to its limited usage, LasManager currently does not support LAS 3.0, 

preferring to support only LAS 1.2 and LAS 2.0. 

 

In February 2017, an update document for LAS Version 2.0 was released to make minor 

changes to the LAS 2.0 specifications to better reflect the technological advances made since 

its introduction.  

 

LasManager validates Las files and displays their metadata so the user can easily modify it. It 

automatically fixes any issues that it can and also enables the user to: 

 

 convert LAS 1.2 files to LAS 2.0 and vice versa 

 wrap and unwrap Las files 

 modify the start and stop depths including reversing the depth sequence in a file 

 resample the curves at a different step size 

 convert depths between metres and feet 

 modify the NULL value 

 modify the well name, logging company name, date of logging, company whose well 

it is, field name, location, county, state, country and unique well identifier 

 modify curve names, descriptions and units 

 delete curves from Las files 

 filter curves 

 merge multiple instances of a curve in a file to a single instance 

 convert Csv files to Las and vice versa.   
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2. Selecting Files to be Checked and Displayed 

When LasManager is opened or Open is selected from the File drop-down menu the Open 

Files window is displayed: 
 

 
 

 

File Type 
 

The File Type box allows the user to choose whether they are opening Las or Csv files. To 

convert one to the other, select Save As from the File drop down menu to save as the other 

file type. 

 

If opening Csv files, the first line in each Csv file must include a curve name for each data 

column in the file. Any columns without a curve name will be ignored. It is preferable but not 

mandatory to also include the units and description of each curve so that they can be 

included in the Las file produced from the Csv file. There are two ways that the user can 

include units for each curve. Either by adding a full-stop and the units to each variable. For 

example: 

 

 
 

or by adding a second header line containing the units. For example: 
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If the units are included on the second row, descriptions of each curve can be included as 

the third row in the file. For example: 

 

  
 

 

 

File Selection 
 

If either of the first two options are selected, the user next selects the required folder: 

 

 
 

Once the required folder has been selected, LasManager checks and displays all the 

appropriate files within the selected folder and if the first option All within a specified folder 

and its subfolders is selected it also checks and displays all the appropriate files in the 

selected folder’s subfolders, the subfolders of the subfolders, the subfolders of the 

subfolders of the subfolders etc. If either of these options are selected LasManager does not 

display any files that include the string Backup in their name. To display these files, select the 

option Select from a specified folder and then select them. 
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If the last option Select from a specified folder is selected, the user next selects the required 

files: 

 

 
 

 

Multiple files can be selected by holding down the Ctrl and/or Shift key while picking files 

with the mouse. 

 

 

 

Display Curves for each File by 
 

When displaying information for each file, LasManager displays a list of the curves that are 

included in the file. There are three possible layouts for displaying this information. The first 

Column for each unique Curve Name has a column for each curve that occurs in at least one 

of the selected files and then for each file a tick if it occurs in the file: 
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The second Column for each Curve Column has a column for each column in the file and 

displays the name of the curve in that column: 

 

 
 

The third Curve Name plus Depth Range of non-null values has a row for each curve in each 

file and displays the depth of the minimum and maximum depths of non-NULL values for the 

curve. It also displays the number of NULL values between these minimum and maximum 

depths: 

 
 

Whenever this option is selected, LasManager must read the entire file and warns the user 

that this may take some time: 

 

 
 

With this option LasManager operates in a read only mode as this option is just for 

summarizing the data. 
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File Validation 
 

The user can select to either Check only the header or Check the entire file. When saving files 

from LasManager, it will automatically fix many of the errors it finds. However, it only saves 

those files in which either it has detected an error it can fix or that the user has modified 

within LasManager. Therefore, if Check only the header is selected and the file contains 

fixable errors in the data but not in the header and no changes have been made to the file, 

the errors will remain as LasManager will not realize that it needs to save a new copy of the 

file. The disadvantage though of selecting Check the entire file is that it will take considerably 

longer to open the files than if Check only the header is selected. The program warns the 

user of this with the following message: 

 

 
 

 

 

Error Messages 
 

The user can select to have any error messages displayed on the screen or sent to a file. If 

the user selects to have them sent to a file, then the user will be prompted to provide a 

folder and file name for this file. The default is for it to create a file called LasManager File 

Errors.txt in the same folder as the files being opened: 
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If no option is selected for communicating error messages, the following warning is given: 
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3. Checking and Displaying the Files 

Once the files have been selected, LasManager reads and checks them. A warning is given if 

any files are missing critical items which are needed for opening the file: 

 

 
 

Critical items include if it does not have: 

 a ~Version, ~Well, ~Curve and ~Ascii Log Data sections 

 a VERS line in the ~Version section 

 a WRAP line in the ~Version section 

 any lines of data 

 

or has: 

 a Las version number other than 1.2 or 2.0 

 a Wrap value other than YES or NO 

 a zero-depth step in the data 

 multiple curves with the same names and units and the multiple instances have 

overlapping intervals of non-NULL data 

 

It also warns the user if it finds any non-standard features that it can fix upon saving the file: 

 

 
 

These include: 

 Unix end of line markers (<LineFeed>). These are converted to Windows end of line 

markers <CarriageReturn><LineFeed> upon saving. 

 Tab characters. These are converted to blanks upon saving. 
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 Non-comment lines in the ~Version, ~Well, ~Curve or ~Parameter sections that do 

not contain a dot delimiter and a colon delimiter somewhere after the dot delimiter. 

These lines will be turned into comments upon saving. 

 Having DEPTH not in the first column. The DEPTH column will be moved to the first 

column upon saving. 

 Not having a well name specified on a WELL line in the ~Well section. The user must 

supply this before the file can be saved.  

 Not having a start depth specified on a STRT line, a stop depth specified on a STOP 

line or a step value on a STEP line in the ~Well section. Any of these that are missing 

are set with appropriate values obtained from the data. 

 Not having a STRT, STOP or STEP value in the ~Well section that matches the data. 

These values are replaced with the appropriate values from the data. 

 Having blank lines in the ~Ascii Log Data section. These are removed upon saving. 

 Not having the same number of values on a line in the ~Ascii Log Data section as the 

number of curves specified in the header. Upon saving, additional NULL values are 

appended to lines having less than the required number and values are trimmed 

from the end of lines with more than the required number. 

 Non-numeric values in the ~Ascii Log Data section. These are replaced with the NULL 

value upon saving. 

 Multiple curves with the same name and units and no overlapping non-NULL value 

sections. These are merged into a single column upon saving. 

 

After checking the files, the LasManager editing screen as shown on the next page is 

displayed. This contains two tables: a Files Table in the upper portion of the screen and a 

Curves Table in the bottom left portion of the screen. It also displays the following Text 

Colour Guide in the bottom right portion of the screen: 

 

 
 

With the tables, the abbreviation for the column is shown at the top of the column and the 

full name of the column that currently has focus is displayed in the bottom left corner of the 

screen. For example, if the user clicks on an item in the Srvc column the description Logging 

Company appears in the bottom left corner of the screen. 
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Files Table 
 

The Files Table displays the: 

 

 File Path of each file’s folder. This column is only displayed though if the All within a 

specified folder and its subfolders option has been selected when the user was 

selecting the files to open or if Display full path of Filenames instead of just subfolder 

names is ticked in the LasManager options. The folder names in this column are 

shown in grey as the files’ folders cannot be modified from LasManager. 

  

 File Name of each selected file. These are shown in grey as they cannot be modified 

from LasManager. 

 

 Las Version Number in the Vers column. The values in this column can only be 1.2 or 

2.0. To convert a Las File from LAS Version 1.2 to 2.0 or vice versa just change the  

entry in this column and on saving the file will be saved as the required version. 

 

 Whether the Las file is Wrapped is displayed in the Wrap column. Wrapped Las files 

have the depth value on its own line and then the values for each depth are shown 

on the subsequent lines which are all no longer than 80 characters (including the 

<carriage return><line feed> end of line marker). To change between files being 

wrapped or not, change the value in the Wrap column to either Y or N and then the 

change will be implemented upon saving the file. 

 

 Well or Hole Name is displayed in the Well column. Any instances where the well 

name cannot be found in the filename are highlighted by showing the well name in 

red. In the example on the previous page, the wells BARNEYSSPG1A and WILGA PARK 

# 4 are shown in red as their names cannot be found in the filenames 

BARNEYSPRINGS1a.las and Bohena4.las. Clearly, BARNEYSSPG1A is an abbreviation of 

the fuller name BARNEYSPRINGS1a shown in the filename, however, the situation 

with WILGA PARK # 4 is not so clear and may require further investigation. 

 

 Start and Stop Depths and the Step Interval are shown in the Strt, Stop and Step 

columns. According to the LAS Version 2.0 documentation released in February 2017, 

the Start and Stop Depths when divided by the Step Depth value must be a whole 

number. Where this not so, LasManager displays the Start and Stop Depths in red: 

 

 
 

 

 Where the Start or Stop Depth or the Step Interval do not match the data in the 

~Ascii Log Data section of the file. LasManager warns the user with a message: 
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And instead of displaying the values in the Las header for these items the values from 

the actual data are displayed in green to indicate that they have been modified: 

 

 
 

 

These modified values will be saved if the file is saved from LasManager. 

 

The user may also modify these values. If the modified Start or Stop depth reduces 

the depth range of the data then data outside the new range will be removed when 

the file is saved and if they increase the depth range then the values on the new 

depth records will be given the NULL value on saving. If a new Step Interval is 

entered, the data will be resampled at this new Step Interval on saving. The user can 

also reverse the depth sequence by simply swapping the Start and Stop Depths and 

reversing the sign on the Step Interval. For example, to reverse the depth sequence 

on: 

 

 
 

 

The Start and Stop Depth and the Step Interval need to be modified to: 

 

 
 

 

This can either be done manually at the keyboard or by selecting Reverse Depth 

Sequence from the Edit dropdown menu: 
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which will swap the Start and Stop Depths and reverse the sign on the Step Interval 

for the currently selected file. 

 

 Depth Units as recorded in the Las header for the Depth curve is displayed. To 

convert all the depths in the data and the Start, Stop and Step in the header between 

metres and feet, change the units for the file. When converting depths, LasManager 

assumes that for both the names of the original and modified units, if they start with 

an “m” or “M” they are in metres and if they start with an “f” or “F” they are in feet. 

 

 Null value for the file. If this is modified by the user then when the file is saved, the 

NULL value in the Las header will be modified and any NULL values in the data will be 

changed from the old NULL value to the new one. 

 

 Date value. Any dates that are not valid dates are shown in red: 

 

 
 

The dates can either be corrected manually at the keyboard or by selecting one of 

Swap Day and Month in Date or Swap Day and Year in Date from the Edit dropdown 

menu or by pressing their hotkeys Ctrl+M and Ctrl+Y: 
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The function will then operate upon the Date in the currently selected file.  

 

 Logging Company (Srvc), Company Name (Comp), Field Name (Fld), Well Location 

(Loc), County (Cnty), State (Stat), Country (Ctry) and Universal Well Index (Uwi), 

each have their own columns and can be edited from the keyboard. 

 

 By scrolling to the right past the information regarding the ~Well section of the file, 

LasManager displays which curves are in the file. The format for this information is 

controlled by the user when they select the files to be opened. See the previous 

section entitled Select the Curves to be Checked and Displayed on how to select the 

format and examples of each format. 

 

 

Curves Table 
 

The Curves Table has a line for each Curve that occurs in at least one of the files displayed in 

the Files Table. It displays: 

 

 A Delete flag which the user can tick to indicate that the particular curve will be 

deleted from all files containing the curve when the files are saved. 

 The Current Name for the curve whose parameters are displayed on this line.  

 

 The Description for the curve. The curve may have different descriptions in different 

files and the one shown is the description found in the first file containing a 

description for this curve. The user can modify the displayed description and then all 

files with this curve will have this new description saved for this curve. 

 

 The New Name for the curve. If the new name is different to the Current Name then 

all files containing this curve will have the Current Name of the curve replaced by this 

New Name. 

 

 A Filter flag which the user can tick to indicate that on saving a new curve will be 

added to the file with a filtered version of the particular curve. The filter is what is 

known as a box filter meaning that the filtered value is created by averaging all the 

readings within an interval as defined by the Filter Size. The default Filter Size is 

seven which means that the new filtered value for a particular depth will be the 

average of the three values before that depth, the value at that depth and the three 
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values after that depth. The new filtered curve is given the New Name for the curve 

along with a suffix of _FILTn where n is the filter size that was used. 

 

 The Filter Size which defaults to seven but the user can change to any positive odd 

number. 

 

 

Other Editing Functions 
 

In addition to the column specific editing functions to swap around parts of the date and 

to reverse the depth sequence there are three other editing functions: 

 Copy Value from Above by selecting this option in the Edit dropdown menu or 

pressing its hotkey F4: 
 

 
 

This function copies down the last non-blank value in the column that you are 

currently editing. 

 

 Find by selecting this option in the Edit dropdown menu or pressing its hotkey Ctrl+F: 

 

 
 

Upon selecting this option, the user is prompted for the field to be searched, the 

value to be searched for and whether the search needs to match the case of the 

search string: 
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On clicking the Find Next button, the current line pointer will move to the next line 

that satisfies the search criteria. If no further instances are found that satisfy the 

search criteria the following prompt appears: 

 

 
 

 

 Find and Replace by selecting this option in the Edit dropdown menu or pressing its 

hotkey Ctrl+H: 

 

 
 

 

Upon selecting this option, the user is prompted for the field to be searched, the 

value to search for, whether the search needs to match the case of the search string 

and the replacement value: 

 

 
 

 

On clicking the Find Next button, the current line pointer will move to the next line 

that satisfies the search criteria and if such a line is found the Replace button will 

become enabled so the user can replace the value. As with the Find function, if on 

pressing the Find Next button no further instances are found that satisfy the search 

criteria the following prompt appears: 
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The user also has the option at any time that the Find and Replace window is open, to 

Replace All instances of the search value by selecting the Replace All button.   
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4. Sorting and Filtering the Files Table 

Sorting the Files Table 
 

The Files Table is initially sorted on the FileName column but the user can sort the table on 

any of the columns apart from those showing the Curves in the file. To sort the Files Table, 

select Sort Files Table from the Tools dropdown menu:  

 

 
 

 

LasManager then displays the following window for the user to select the column on which 

to sort: 

 
 

 

Sorting the example Files Table on the Srvc column produces the following display: 
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Filtering the Files Table 
 

The user can filter which files are displayed in the Files Table. To filter the Files Table, select 

Filter Files Table from the Tools dropdown menu:  

 

 
 

 

LasManager then displays the following window for the user to select the column on which 

to filter and the desired value for this column: 

 

 
 

 

The columns Well, Strt, Stop and Date can have values shown in red and so if one of these 

columns is selected, both the Select Values to Display and Display only Values shown in Red 

are available but for all other columns only the first option is available. The value selection 

box is populated with all the options in the selected column for the files that have been 

opened. Filtering the example Files Table on the Srvc column equalling RUTHERFORD 

produces the following display: 

 

 
 

Note that even though the logging date for the first file in this list has a valid date, this date 

is probably in American date format like all the other dates supplied by this Service Company 

and is therefore probably the 5th July 2007 rather than the 7th May 2007. 
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By pressing the Ctrl and/or Shift keys while selecting the desired values, multiple values can 

be selected for the filter: 

 

 
 

which provides the following result on the example data set: 

 

 
 

If Date is chosen for Column on which to filter Files Table and Display only Values shown in 

Red is selected the results for the example data are: 

 

 
 

 

Once the data is Filtered then if Filter Files Table is chosen again, LasManager further filters 

the current results but first warns the user: 
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For example, in the example data set, to display all the Eastern Gas files where Reeves 

Wireline was the Service Company, first filter on Comp being Eastern Star (including 

variations on the name): 

 

 
 

This generates the following results: 

 

 
  

Then filter on Srvc equal to Reeves Wireline to produce the following results: 
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5. Settings 

Select Las File Parameters to Display 
 

Except for the FileName column and the Curve columns, the columns in the Files Table can 

be displayed or hidden. To change whether columns are displayed or not, select Select Las 

File Parameters to Display from the Settings drop down menu: 

 

 
  

 

Next the parameters to display on the screen are requested: 

 

 
 

 

The selection is saved and used every time files are opened in LasManager even after the 

user closes LasManager and reopens it.  
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Options 
 

The full path for Filenames and the curve units for each curve can be displayed. To select or 

deselect these options select Options from the drop-down Settings menu: 

 

 
 

 

Then set the required options in the following window: 

 

 
 

 

When opening files with All within a specified folder and its subfolders ticked, LasManager 

displays the subfolder names along with the filename. For example: 

 

 
 

 

If Display full path of Filenames instead of just subfolder names is ticked in the options then 

the full path name is shown, not only where subfolders need to be shown but for all files. For 

example: 

 

 
 

If Display Curve Units appended to Curve Names is ticked then the units are shown along 

with the curve names both in the Files Table and in the Curves Table. The user can then 

modify the unit names as well as the curve names by editing the entries in the Curves Table. 

 

For example, when this option and Column for each unique Curve Name in the File opening 

window are ticked, the Files Table for the example data will display: 
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From this display it is now easy to see which files have their Bit Size (BIT) recorded in inches 

and which in mms. 

 

 

When Display Curve Units appended to Curve Names and Column for each Curve Column in 

the file opening window are ticked, the Files Table for the example data will display: 

 

 
 

 

When Display Curve Units appended to Curve Names is ticked the Curves Table for the 

example data will display: 
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6. Saving Files 

There are four options for saving the results: 

1) Save which will save all the files that need to be modified, these will include both 

those files that LasManager has indicated need to be modified due to not complying 

to the LAS standard and those that the user has made changes to. 

  

2) Save As which will save all the open files whether they need to be modified or not. 

Save As includes options to save the files to a different folder, place a suffix on the 

filename and/or change the file type between Las and Csv. 

 

3) Export Files Table as a CSV files. 

 

4) Export Curves Table as a CSV file. 

 

If any files need to be modified and they have not been saved, LasManager will warn with 

the following message that they have not been saved before a new set of files opened or 

LasManager is closed: 

 

 
 

 

Save Files 
 

To save the files that need to be modified select Save from the File dropdown menu or press 

its hotkey Ctrl+S: 

 
 

 

Before each file is saved the original copy is renamed with a “ - Backup” suffix added to its 

filename.  If there is already a file with this name then it is renamed with a “ - Backup(2)” 

suffix added to it. If this name already exists then it uses “ - Backup(3)” and so on.  
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Save Files with Save As 
 

To save the files to a different folder, place a suffix on the filename and/or change the file 

type between Las and Csv select Save As from the File dropdown menu or press its hotkey 

Ctrl+E: 

 

 
 

 

Next the following information is requested: 

 

 
 

 

Whenever a file already exists with the same name as the desired filename of one of the files 

being saved, the user is warned and asked if they want to overwrite the previous file: 

 

 
  



 GEOCHECK PTY LTD  LASMANAGER 

 User Guide – January 2019  29 

Export Tables as CSV files 
 

To export the information in the Files Table to a Csv file select Export Table as CSV files from 

the File drop down menu and then select the Files Table option: 

 

 
 

 

The user is then prompted for the folder and filename for the Files Table Csv file: 

 

 
 

 

To export the information in the Curves Table to a Csv file select Export Table as CSV files 

from the File drop down menu and then select the Curves Table option: 

 

 
 

The user is then prompted for the folder and filename for the Curves Table Csv file. 
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7. Additional Information 

Additional information can be obtained by selecting one of the options from the Help 

dropdown menu: 

 

 
 

There are four options: 

  

1. LasManager User Guide which displays the LasManager User Guide that you are 

currently reading. 

 

2. Las Standard v2.0 which displays a copy of the latest LAS Standard which was 

updated by the Canadian Well Logging Society in February 2017.  

 

3. Additional Related Apps which displays a list of other Apps and Services provided by 

the LasManager authors: 
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4. About LasManager which displays a synopsis of the program, the release number of 

LasManager and the contact for support: 

 

 


